B² weave not showing all section info
View previous topic | View next topic >
Post new topic Reply to topic
M.A.I.L. Forum Index -> M.A.I.L. Help
   
Author Message

Joined: July 1, 2014
Posts: 67
Submissions: 7
Location: FL, USA

B² weave not showing all section info
Reply with quote
Posted on Sun Mar 15, 2015 1:20 pm
Link to Post: Link to Post

On the weave page the "Random Gallery Items Tagged as using this Weave" section is not pulling any items from the gallery.

I can only assume the section is having trouble with the superscript in the weave title. If you do a search for this weave there six images tagged with this weave.

Joined: January 17, 2013
Posts: 373
Submissions: 5
Location: Probably in the garage...

Reply with quote
Posted on Sun Mar 15, 2015 1:44 pm
Link to Post: Link to Post

Sounds like a task for DL. Chances are the search filter isn't including what's in <sup></sup> tags as a part of the search string.

This should be moved to the M.A.I.L. Help section of the forums to ensure DL is aware of the issue.


Mostly Harmless

Joined: March 26, 2002
Posts: 1877
Submissions: 549
Location: Chainmailland, Chainmailia

Reply with quote
Posted on Sun Mar 15, 2015 1:47 pm
Link to Post: Link to Post

Kegas76 wrote:
I can only assume the section is having trouble with the superscript in the weave title. If you do a search for this weave there six images tagged with this weave.
That is correct.

The gallery items though should link back to the weave.

Same with B²+1, naturally.


Chainmailbasket.com (2019-01-01) - 376 + 79

Joined: July 1, 2014
Posts: 67
Submissions: 7
Location: FL, USA

Reply with quote
Posted on Tue Mar 31, 2015 8:32 pm
Link to Post: Link to Post

DL, could you take a look at this issue?

Thanks Smile

Joined: August 30, 2008
Posts: 3058
Submissions: 20
Location: Burlington, ON, Canada

Reply with quote
Posted on Tue Mar 31, 2015 10:56 pm
Link to Post: Link to Post

Kegas76 wrote:
DL, could you take a look at this issue?

Thanks Smile


It's an SQL Issue, that there isn't actually a decent workaround for...



Joined: July 1, 2014
Posts: 67
Submissions: 7
Location: FL, USA

Reply with quote
Posted on Wed Apr 01, 2015 1:51 am
Link to Post: Link to Post

Is there anything we can do to the weave names so they will work in the galleries? On the plus side these two or three weaves probably have less than ten images between them.

I imagine there might be some hesitance in changing the name of someone's weave. Do the AKA names work with the weave tag? If not can that be changed?

---
I just tested it in preview and weave=Bicubix Blocks shows as - Any chance this can applied to the Image Tag section instead of the weavetags=B%82

Joined: August 30, 2008
Posts: 3058
Submissions: 20
Location: Burlington, ON, Canada

Reply with quote
Posted on Wed Apr 01, 2015 4:28 pm
Link to Post: Link to Post

Kegas76 wrote:
Is there anything we can do to the weave names so they will work in the galleries? On the plus side these two or three weaves probably have less than ten images between them.

I imagine there might be some hesitance in changing the name of someone's weave. Do the AKA names work with the weave tag? If not can that be changed?

---
I just tested it in preview and weave=Bicubix Blocks shows as - Any chance this can applied to the Image Tag section instead of the weavetags=B%82


There's a lot of red tape, in terms of what can and cannot be done. The system(as designed) neglects special characters, due to a problem with SQL Queries. The alternatives, are to use a different (read: Slower) SQL query, or re code the system to work quickly without using that query. Also possible, certainly, renaming weaves... The are many possible solutions, and it is on the list of things to deal with... However, it's further down the list than you might like...



Joined: July 1, 2014
Posts: 67
Submissions: 7
Location: FL, USA

Reply with quote
Posted on Thu Apr 02, 2015 2:07 pm
Link to Post: Link to Post

I totally get the priority status.

My enthusiasm for the issue is an occupational byproduct. I get paid to bug developers over tiny issues until they give me an answer I can barely understand. Razz

Joined: August 30, 2008
Posts: 3058
Submissions: 20
Location: Burlington, ON, Canada

Reply with quote
Posted on Mon Dec 21, 2015 3:45 am
Link to Post: Link to Post

This bug shot tonight.
http://www.mailleartisans.org/board/viewtopic.php?t=19214



Post new topic Reply to topic
Jump to:  
Page 1 of 1
All times are GMT. The time now is Wed Jul 17, 2019 9:10 pm
M.A.I.L. Forum Index -> M.A.I.L. Help
Display posts from previous: