Gallery Feed dates showing as December 31, 1969, 7:00
View previous topic | View next topic >
Post new topic Reply to topic
M.A.I.L. Forum Index -> M.A.I.L. Help
   
Author Message

Joined: January 17, 2013
Posts: 373
Submissions: 5
Location: Probably in the garage...

Gallery Feed dates showing as December 31, 1969, 7:00
Reply with quote
Posted on Sat Jul 11, 2015 11:43 pm
Link to Post: Link to Post

I was looking at my measly gallery feed and noticed the above noted date and time attached to my submissions or anyone elses via their gallery feed.
The upload dates for the items in the gallery are correct but when viewed via a "galley feed" they are all 1969 dates.
Have they always been off? A cursory search of the forums didn't reveal any notes but it was a quick search.
It doesn't bother me, I'm just curious as to why it's setup this way if it's intentional and if it's not by design it maybe a good idea to check the health of the database.
I know, no DL to bounce off Sad but if anyone has some insight I'd love to hear it.


Mostly Harmless

Joined: August 05, 2010
Posts: 599
Submissions: 28
Location: Bar Harbor, ME, USA

Reply with quote
Posted on Sun Jul 12, 2015 1:25 am
Link to Post: Link to Post

Unless I'm not finding the "gallery feed" correctly, the timestamps on gallery images are just fine for me.


while(!project.isFinished())
project.addRing();
// Maille Code V2.0 T7.1 R5.6 Eo.n Fper MFe.s Wsm Caws G0.8-1.6 I2.4-8.0 Pn Dcdejst Xw1 S07

Joined: January 17, 2013
Posts: 373
Submissions: 5
Location: Probably in the garage...

Reply with quote
Posted on Sun Jul 12, 2015 1:40 am
Link to Post: Link to Post

Hover over the black circle with the down arrow below my (or anyone elses) name/profile and click on "View Gallery Feed".


Mostly Harmless

Joined: August 05, 2010
Posts: 599
Submissions: 28
Location: Bar Harbor, ME, USA

Reply with quote
Posted on Sun Jul 12, 2015 12:56 pm
Link to Post: Link to Post

Aah, yes. Those are all wrong for me too. Seems like a typo in the database call (feeding in a default unix epoc date).


while(!project.isFinished())
project.addRing();
// Maille Code V2.0 T7.1 R5.6 Eo.n Fper MFe.s Wsm Caws G0.8-1.6 I2.4-8.0 Pn Dcdejst Xw1 S07

Joined: January 17, 2013
Posts: 373
Submissions: 5
Location: Probably in the garage...

Reply with quote
Posted on Sun Jul 12, 2015 1:13 pm
Link to Post: Link to Post

Thanks for confirming the behaviour.
If the call is intentionally made that way (for whatever reason) it shouldn't matter but if it should be feeding the proper date then there could be an issue with the call, the indexes or the DB itself. I'm hoping for the former. I don't do much with DBs in general but when values get set back to defaults, it usually means there's a problem somewhere.


Mostly Harmless

Joined: August 05, 2010
Posts: 599
Submissions: 28
Location: Bar Harbor, ME, USA

Reply with quote
Posted on Sun Jul 12, 2015 1:16 pm
Link to Post: Link to Post

DB seems fine since profile pages have the correct timestamps.


while(!project.isFinished())
project.addRing();
// Maille Code V2.0 T7.1 R5.6 Eo.n Fper MFe.s Wsm Caws G0.8-1.6 I2.4-8.0 Pn Dcdejst Xw1 S07

Joined: December 22, 2007
Posts: 4610
Submissions: 106
Location: Hampton, Virginia USA

Reply with quote
Posted on Mon Jul 13, 2015 1:01 am
Link to Post: Link to Post

Personally, as a complete idiot concerning coding, I wouldn't worry about it...


"I am a leaf on the wind." ~ Wash
Lorraine's Chains
Gallery Submission Guidelines

Post new topic Reply to topic
Jump to:  
Page 1 of 1
All times are GMT. The time now is Tue Jul 16, 2019 4:53 pm
M.A.I.L. Forum Index -> M.A.I.L. Help
Display posts from previous: